[PATCH] resolver does not try other nameservers on SERVFAIL

Bernhard Reutner-Fischer rep.dot.nop at gmail.com
Wed Apr 23 14:04:46 UTC 2014


On 3 March 2014 11:46, Michel Stam <michel.uclibc at reverze.net> wrote:
> Commit e1420eca7374cd8f583e9d774c890645a205aaee fixed a bug where a
> response code should mean the next server is tried. However, it tries
> only the next search domain, and never skips to the next server.
>
> In my specific situation, I was using tmdns as a DNS -> mDNS bridge to
> resolve mDNS names. tmdns returns SERVFAIL on any domain that does not end
> in .local.
>
> uClibc then tries all the search domains in /etc/resolv.conf and gives up,
> not jumping to the next nameserver in the list (in my case the real
> nameserver). Thus, any non-.local domain never got resolved.
>
> My resolv.conf;
> domain bla.net
> search bla.net
> nameserver 127.0.0.1
> nameserver 172.16.1.1
>
> The patch I have attached basically allows SERVFAIL to go back to the case
> as it was before 0.9.32, except that search domains are still tried.
>
Applied, thanks!


More information about the uClibc mailing list