Compiling binutils 2.18.

Manuel Cano manuel at
Tue Jun 3 20:51:51 UTC 2008


I've searched for this error but I haven't found an answer.

When I compile binutils 2.18 I get an error from info (missing makeinfo)
but I've compiled texinfo and installed in buildroot (a stock buildroot)
and I have the same error.
I run 'makeinfo' manually and it is there, but the binutils package
tells me that it isn't there.

I'm using
chroot'ed in an Ubuntu box (but Ubuntu shouldn't be a problem, isn't

I hope this is something known because I'm desperated now. I've tryied
to compile a complete toolchain in several systems (Slackware, Arch,
Ubuntu and others) to no avail, but once I've found uClibc and tested
some software I absolutely want uClibc because all soft I've tryied runs
much faster.

The make output (from the warning):

WARNING: `makeinfo' is missing on your system.  You should only need it
         you modified a `.texi' or `.texinfo' file, or any other file
         indirectly affecting the aspect of the manual.  The spurious
         call might also be the consequence of using a buggy
`make' (AIX,
         DU, IRIX).  You might want to install the `Texinfo' package or
         the `GNU make' package.  Grab either from any GNU archive site.
make[3]: *** [] Error 1
make[3]: Leaving directory `/usr/src/build-binutils/bfd/doc'
Making info in po
make[3]: Entering directory `/usr/src/build-binutils/bfd/po'
( if test 'x../../../binutils-2.18/bfd/po' != 'x.'; then \
    posrcprefix='../../../binutils-2.18/bfd/'; \
  else \
    posrcprefix="../"; \
  fi; \
    && (sed -e '/^#/d' \
            -e '/^[     ]*$/d' \
            -e "s at .*@   $posrcprefix& \\\\@"
< ../../../binutils-2.18/bfd/po/ \
        | sed -e '$s/\\$//') > SRC-POTFILES-t \
    && chmod a-w SRC-POTFILES-t \
    && (sed -e '/^#/d' \
            -e '/^[     ]*$/d' \
            -e "s at .*@   ../& \\\\@"
< ../../../binutils-2.18/bfd/po/ \
        | sed -e '$s/\\$//') > BLD-POTFILES-t \
    && chmod a-w BLD-POTFILES-t \
cd .. \
  && CONFIG_FILES=po/ \
     CONFIG_HEADERS= /bin/sh ./config.status
config.status: creating po/
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing default-1 commands
config.status: executing bfd_stdint.h commands
config.status: executing default commands
make[3]: Leaving directory `/usr/src/build-binutils/bfd/po'
make[3]: Entering directory `/usr/src/build-binutils/bfd/po'
make[3]: Nothing to be done for `info'.
make[3]: Leaving directory `/usr/src/build-binutils/bfd/po'
make[3]: Entering directory `/usr/src/build-binutils/bfd'
make[3]: Nothing to be done for `info-am'.
make[3]: Leaving directory `/usr/src/build-binutils/bfd'
make[2]: *** [info-recursive] Error 1
make[2]: Leaving directory `/usr/src/build-binutils/bfd'
make[1]: *** [all-bfd] Error 2
make[1]: Leaving directory `/usr/src/build-binutils'
make: *** [all] Error 2

What I've typed:

(root) /usr/src/build-binutils$ makeinfo 
makeinfo: missing file argument.
Try `makeinfo --help' for more information.
(root) /usr/src/build-binutils$ 

Thank you for your patience.


More information about the uClibc mailing list