buildroot doesn't build

Bernhard Fischer rep.dot.nop at gmail.com
Mon Jul 30 07:41:18 UTC 2007


On Sun, Jul 29, 2007 at 02:38:28PM +0300, Alex Shnitman wrote:
>Hi,
>
>Thanks. I took the latest release today and it builds fine. Now I have a
>different problem. When I try to run the generated busybox as a chrooted
>shell on the target (i.e. mount the filesystem as a loopback device,
>enter the mount point and type "chroot . /bin/sh") I get an error
>"Illegal instruction". I'm working on TI's DaVinci which includes an
>ARM926 core. I tried building for arm926t and generic_arm, and tried
>both OABI and EABI -- always the same problem.


generic arm should probably work. Make sure that you really rebuild all
packages involved when you change the target optimization.

>
>I have to say that when I configure buildroot to use TI's toolchain
>instead of its own, and then use the glibc that came with it, the same
>thing works fine. Of course it takes lots of space due to glibc.
>
>Any ideas why I might be getting an illegal instruction with uClibc?

SIGILL in general means that you attempted to issue an insn that is not
supported by your target (obviously). Perhaps see which instruction this
is triggering and where it comes from.



More information about the uClibc mailing list