buildroot doesn't build

Alex Shnitman AlexS at
Sun Jul 29 11:38:28 UTC 2007


Thanks. I took the latest release today and it builds fine. Now I have a
different problem. When I try to run the generated busybox as a chrooted
shell on the target (i.e. mount the filesystem as a loopback device,
enter the mount point and type "chroot . /bin/sh") I get an error
"Illegal instruction". I'm working on TI's DaVinci which includes an
ARM926 core. I tried building for arm926t and generic_arm, and tried
both OABI and EABI -- always the same problem.

I have to say that when I configure buildroot to use TI's toolchain
instead of its own, and then use the glibc that came with it, the same
thing works fine. Of course it takes lots of space due to glibc.

Any ideas why I might be getting an illegal instruction with uClibc?

Please tell me if you need any other info that might be relevant to the


-----Original Message-----
From: Bernhard Fischer [ at] 
Sent: Friday, July 27, 2007 3:56 PM
To: Alex Shnitman
Cc: uclibc at
Subject: Re: buildroot doesn't build

On Thu, Jul 26, 2007 at 12:13:06PM +0300, Alex Shnitman wrote:
>I'm trying to build the latest snapshot of buildroot (20070725) and it
>fails with the following error:
>ge tmp-macro_list macro_list
>echo timestamp > s-macro_list
>The directory that should contain system headers does not exist:
>  /home/alexsh/buildroot/toolchain_build_arm/uClibc_dev//usr/include
>I changed almost nothing in the default configuration -- just the name
>of the project and the architecture (arm926). I'm attaching the main
>.config file just in case.
>Are there any releses of uClibc that are tested at least for
>compilability, or is it only daily snapshots? If so, can you perhaps
>point me to a certain date which is known to be good?

More information about the uClibc mailing list