Ping! malloc bug, and PIC and flat shared library support for m68k

Rick Garcia rick at liveoaklogic.com
Fri Nov 3 20:08:42 UTC 2006


Richard Sandiford wrote:
> Richard Sandiford <richard at codesourcery.com> writes:
>> Mike Frysinger <vapier at gentoo.org> writes:
>>> On Wednesday 25 October 2006 04:20, Richard Sandiford wrote:
>>>> Would the uClibc patch be acceptable now that the ld-elf2flt patch is in?
>>> to be honest, i wouldnt have made it wait on the elf2flt patch ;)
>> Thanks. ;)
>>
>>> if you could update/verify/all-that-fun-stuff and post a new patch for
>>> latest svn, that'd be awesome
>> It turns out that the original patch still applies cleanly and tests OK.
> 
> Is the patch OK?  FWIW, I've reattached it below.  (To be clear,
> the patch is independent of the malloc bug I mentioned later on.)
> 
>> However, retesting on m68k showed up a problem that had appeared in
>> uClibc since the last time I tried.  [...]
> 
> How about this patch?  I'd like to get the bug fixed before the upcoming
> release.  As things stand, uClibc trunk is basically unusable on m68k systems.

	I've got a quick question about the status of m68knommu on uClibc - 
here's my situation :

	I've been working on getting busybox up on a m68knommu system. As an 
aside, I tried building "hello, world" to test alongside bb, and I can't 
believe how much trouble it's giving me.  I'm cross-compiling against 
uClibc-0.9.28 built for m68knommu.  I'm not going to go through every 
iteration/commandline I've tried, but this output is typical of what I'm 
seeing :

 > m68k-none-elf-gcc -c -g \
 >	-I/home/Rick/usr/m68k-linux-uclibc/usr/include \
 >	hello.c -o hello.o
 > m68k-none-elf-gcc \
 >	hello.o  \
 >	-static -nostdinc -nostdlib -Wl,-elf2flt \
 >	-L/home/Rick/usr/m68k-linux-uclibc/usr/lib \
 >	-o hello
 >/usr/local/lib/gcc/m68k-none-elf/3.4.4/../../../../m68k-none-elf/bin/ld.real: 
 > warning: cannot find entry symbol _start; defaulting to 00000000
 > hello.o: In function `main':
 > /home/Rick/src/m68k/hello/hello.c:4: undefined reference to `printf'
 > collect2: ld returned 1 exit status
 > make: *** [hello] Error 1

	If I specifically point to the uClibc's libc.a and crt0.o on the 
command line, then it gives me a whole bevy of other unfound files and 
symbols.  (stddef.h, stdarg.h, ect.)  If I leave off the -nostdlib, then 
it attempts to build against newlib (which was used to build the 
compiler) instead of uClibc.

	Is this a symptom of the breakage you're referring to?  I've been able 
to get busybox compiling & running against this same uClibc without the 
kind of trouble that it's giving me for hello.c.

-- 
  - Rick Garcia
  Live Oak Logic



More information about the uClibc mailing list