[uClibc] BuildRoot installation problem

pavan shah paavan23 at rediffmail.com
Fri Jun 10 10:03:29 UTC 2005


hello all!!

I am a newbie for buildroot installation and configuration.

I am installing Minimal linux in a 128 MB compact flash card.
I have used Syslinux as boot loader and build root to build my root filesystem.

I did default buildroot installation on my flash card and it worked.
I was able to get the login prompt.I can log in with default username and blank password.
But i can't login with root user.What is the default password for root user?

I have tried following to change the rooot password.
1) mounted my flash card partition to /mnt/target
2)#chroot /mnt/target passwd root
when it asks fro new password ,i specify it,but can't log in after changing the password.

What if i want to create a new user with root privileges?
My goal is to setup basic linux ,apache and php on my flash card..
Does anyone know lightweight apache that requires lesser space?

I logged in as default user and blank password.
But at that time ,i could not ping 127.0.0.1,what can be the reason for that?

I want to configure eth0 also and wish to access internet through flash card.
Are there any special configurations related to network in buildroot?


Thanks in advance..
regards,
pavan.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.busybox.net/pipermail/uclibc/attachments/20050610/6d963889/attachment-0001.htm 


More information about the uClibc mailing list