[uClibc] Cleanups for uClibc

Erik Andersen andersen at codepoet.org
Wed Oct 6 19:11:08 UTC 2004


On Wed Oct 06, 2004 at 10:14:22AM +0200, Peter S. Mazinger wrote:
> 2. corrects libpthread_db name (I do not know why libpthread_db.so uses 
> libpthread_db.so.1 instead of libpthread_db.so.$(MAJOR_VERSION) as soname)

When gdb needs to debug an app using pthreads, in gdb/gdb/thread-db.c
it does:

	#define LIBTHREAD_DB_SO "libthread_db.so.1"
	handle = dlopen (LIBTHREAD_DB_SO, RTLD_NOW);
	<blah>

which is how it can discover the internal state of pthreads.
If you change the name of this library, gdb will not be able
to dlopen libthread_db.so.1 and debugging pthreads will fail,

 -Erik

--
Erik B. Andersen             http://codepoet-consulting.com/
--This message was written using 73% post-consumer electrons--



More information about the uClibc mailing list