[uClibc] Coreutils build error.

Rob Kramer robk at starhub.net.sg
Tue Dec 21 16:28:41 UTC 2004


Hi all,

I'm new to uclibc, so I hope this isn't a FAQ that I missed :)
My buildroot make fails on coreutils:

<snip>
Making install in src
make[2]: Entering directory 
`/home/rob/oe/uclibc/buildroot/build_i386/coreutils-5.0/src'
make[3]: Entering directory 
`/home/rob/oe/uclibc/buildroot/build_i386/coreutils-5.0/src'
/bin/sh ../config/mkinstalldirs /home/rob/oe/uclibc/buildroot/build_i386/root/usr/bin
  ../config/install-sh -c 
chgrp /home/rob/oe/uclibc/buildroot/build_i386/root/usr/bin/chgrp
../config/install-sh: line 206: ./basename: No such file or directory
../config/install-sh: line 213: ./basename: No such file or directory
../config/install-sh: line 224: ./cp: No such file or directory
../config/install-sh: line 270: ./rm: No such file or directory
make[3]: *** [install-binPROGRAMS] Error 1
make[3]: Leaving directory 
`/home/rob/oe/uclibc/buildroot/build_i386/coreutils-5.0/src'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory 
`/home/rob/oe/uclibc/buildroot/build_i386/coreutils-5.0/src'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory 
`/home/rob/oe/uclibc/buildroot/build_i386/coreutils-5.0'
make: *** [/home/rob/oe/uclibc/buildroot/build_i386/root/bin/vdir] Error 2

It seems to execute the target version of basename, cp, etc. Any idea what I'm 
doing wrong?

My target is i386 / Nehemiah-c3. I included both busybox and coreutils (or 
rather, all the stuff in the 'minimum required for dev. system' section in 
menuconfig).

(Not sure if I should include my .config or other info here)

Cheers,

    Rob


-- 
aibohphobia
      n. : fear of palindromes



More information about the uClibc mailing list