<SPAM> Re: [uClibc] ld/gcc problem with latest buildroot with i586 target

Mudrony Laszlo mudry at mudry.hu
Mon Aug 30 13:39:55 UTC 2004


Steve Rodgers wrote:

>gcc (gcc-3.3.4) wants to send option --as-needed to ld (binutils-2.14.90.0.6) 
>and ld doesn't understand the switch. 
>
>  
>
I've experienced the same before, and modified the binutils makefile to fetch and compile
binutils 2.15.. I've also fetched the debian patches for binutils, and migrated uclibc's config patches
into them. My work might be poor quality, but it works for me.

I've made a cvs diff -u and attached it as mudry.diff. I've also attahed it as mudry_binutils.diff, but
all non binutils stuff removed.

The reson for the first diff, that it has some other updates to stuff like newer autoconf, libtool,ltrace,etc
Witch work (and sometime required). As one might note it also has an optional makefile for gcc 3.4, wich I've failed to make
work g++. If someone solved that I would be grateful to hear about.

Again do not expect my patches to be excellet (I'm quite new to uclibc), but someone might be able to enhance them..

-------------- next part --------------
A non-text attachment was scrubbed...
Name: mudry.diff.gz
Type: application/x-gzip
Size: 6855 bytes
Desc: not available
Url : http://lists.busybox.net/pipermail/uclibc/attachments/20040830/70477a49/attachment.bin 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mudry_binutils.diff.gz
Type: application/x-gzip
Size: 4829 bytes
Desc: not available
Url : http://lists.busybox.net/pipermail/uclibc/attachments/20040830/70477a49/attachment-0001.bin 


More information about the uClibc mailing list