[uClibc] ld/gcc problem with latest buildroot with i586 target

Steve Rodgers hwstar at rodgers.sdcoxmail.com
Mon Aug 30 04:54:44 UTC 2004


Thanks for the response, As the link you sent states, it looks like a newer
binutils package is needed. This is all fine and good, but I don't know where 
to start when it comes resolving the patch failures when a later version of 
binutuls is downloaded and used instead. 

Has anyone else experienced this problem with buildroot using an i386 target?
If so what did you do get the patches to apply against a newer version of 
binutils to work in place of the one specified by default?

Steve.

On Sunday 29 August 2004 21:23, Mike Frysinger wrote:
> On Monday 30 August 2004 12:06 am, Steve Rodgers wrote:
> > gcc (gcc-3.3.4) wants to send option --as-needed to ld
> > (binutils-2.14.90.0.6) and ld doesn't understand the switch.
>
> you might want to review this bug for in-depth info about what's happening:
> http://bugs.gentoo.org/show_bug.cgi?id=49363
> -mike



More information about the uClibc mailing list