[uClibc] RE: *solved* "arm-linux-g++: No such file or directory"

Brian Fliege BrianF at apcon.com
Thu Aug 26 18:03:46 UTC 2004


    Nevermind.  Further investigation of the ccache program and the
bin-ccache directory revealed that using arm-linux-uclibc-g++ instead of
arm-linux-g++ fixes the problem.  Maybe it would help to put another
symlink in there for arm-linux-g++?

 -Brian

 

 

  _____  

From: Brian Fliege 
Sent: Thursday, August 26, 2004 10:01 AM
To: (uclibc at uclibc.org)
Subject: "arm-linux-g++: No such file or directory"

 

    I am getting a rather odd error with the uClibc arm-linux toolchain.
A couple of weeks ago, I built the uClibc toolchain using the build
scripts from uclibc.org.  I have been using arm-linux-gcc just fine in
these past couple of weeks.  Today, I had a project come up that needs
C++ code cross-compiled to the ARM processor, but arm-linux-g++ seems to
always kick back the mysterious error "No such file or directory."  

 

    In searching the mail archives, I found this issue
[http://www.uclibc.org/lists/uclibc/2003-April/006086.html] that
mentions a problem with the same error message and includes a fix with
C++ and STL.  The code I am trying to compile actually makes use of STL,
but I do not think this is the issue, as I get the same error when
invoking arm-linux-g++ without any arguments.  At any rate, I attempted
the fix (-I to include /usr/include/c++, as the mail says and I also
tried /usr/local/arm-linux-uclibc/toolcahin_arm/include/c++, as that
seemed more appropriate to this particular toolchain).

 

    At any rate, I am not entirely sure what is wrong.  The error
message is rather vague.  Both arm-linux-gcc and arm-linux-g++ exist,
and happen to be symlinks pointing to the same file, so I am not sure
why I would be getting this error.

 

    If more specifics are needed, here are some snippets of what occurs
when I run various things:

 

### The error that I get:

[brianf at localhost WebminAlpha]$ make -f Makefile.ARM

arm-linux-g++ -c -o src/util.o  -g -Wall  -I. -DLINUX  src/util.cc

arm-linux-g++: No such file or directory

make: *** [src/util.o] Error 1

 

### It occurs when invoking g++ with no command line arguments:

[brianf at localhost WebminAlpha]$ arm-linux-g++

arm-linux-g++: No such file or directory

 

### I am talking to the right program

[brianf at localhost WebminAlpha]$ which arm-linux-g++

/usr/local/arm-linux-uclibc/toolchain_arm/bin/arm-linux-g++

 

### gcc runs fine:

[brianf at localhost WebminAlpha]$ arm-linux-gcc -v

Reading specs from
/usr/local/arm-linux-uclibc/toolchain_arm/bin-ccache/../lib/gcc-lib/arm-
linux-uclibc/3.3.4/specs

Configured with:
/usr/local/arm-linux-uclibc/toolchain_build_arm/gcc-3.3.4/configure
--prefix=/usr/local/arm-linux-uclibc/toolchain_arm
--build=i386-pc-linux-gnu --host=i386-pc-linux-gnu
--target=arm-linux-uclibc --enable-languages=c,c++ --enable-shared
--disable-__cxa_atexit --enable-target-optspace --with-gnu-ld
--disable-nls --enable-multilib --enable-sjlj-exceptions

Thread model: posix

gcc version 3.3.4

 

### Both gcc and g++ point to the same program (ccache):

[brianf at localhost WebminAlpha]$ ls -l
/usr/local/arm-linux-uclibc/toolchain_arm/bin/arm-linux-g*

lrwxrwxrwx    1 brianf   brianf         17 Aug 23 10:53
/usr/local/arm-linux-uclibc/toolchain_arm/bin/arm-linux-g++ ->
../usr/bin/ccache

lrwxrwxrwx    1 brianf   brianf         17 Aug 23 10:53
/usr/local/arm-linux-uclibc/toolchain_arm/bin/arm-linux-gcc ->
../usr/bin/ccache

lrwxrwxrwx    1 brianf   brianf         26 Aug 23 10:53
/usr/local/arm-linux-uclibc/toolchain_arm/bin/arm-linux-gcc-3.3.4 ->
arm-linux-uclibc-gcc-3.3.4

lrwxrwxrwx    1 brianf   brianf         23 Aug 23 10:53
/usr/local/arm-linux-uclibc/toolchain_arm/bin/arm-linux-gccbug ->
arm-linux-uclibc-gccbug

lrwxrwxrwx    1 brianf   brianf         21 Aug 23 10:53
/usr/local/arm-linux-uclibc/toolchain_arm/bin/arm-linux-gcov ->
arm-linux-uclibc-gcov

 

Any thoughts?

 -Brian

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.busybox.net/pipermail/uclibc/attachments/20040826/b028c0e2/attachment.htm 


More information about the uClibc mailing list