[uClibc] Link error on SH4

Mike Miller mmiller at prga.com
Sun Oct 26 14:33:49 UTC 2003

Sigh.  OK - the problem was my path was pointing to /usr/local/uclibc
instead of /usr/sh-linux-uclibc.  BusyBox had explicit pathing to uclibc,
which is why it worked.  Bottom line is if you get this like error you
probably have a path problem or failed to enable ADD_LIBGCC_FUNCTIONS.


-----Original Message-----
From: uclibc-bounces at uclibc.org [mailto:uclibc-bounces at uclibc.org] On Behalf
Of Michael D. Miller
Sent: Sunday, October 26, 2003 12:26 AM
To: uclibc at uclibc.org
Subject: [uClibc] Link error on SH4

I'm trying to link a simple hello world app using the latest 10/25 snapshot.
I get a link error about an undefined reference to '__udivsi3_i4' in
fwrite_unlocked.  The target is a SH4 processor.  I get the same behavior
with the 9/17 release.  I configured uclibc with the ADD_LIBGCC_FUNCTIONS.
This looks similar to the problem Paul van Gool reported, but I didn't find
any resolution to the issue.
I'm using gcc version 3.3.1 from the crosstool 0.24 chain.  I am able to
compile and run BusyBox with uclibc statically linked.  I tried removing
thread support from the uclibc configuration but the results were the same.
Explicitly adding -lgcc to force linking the library had no effect.
Any ideas what I'm doing wrong? 

More information about the uClibc mailing list