[uClibc] Getting error when MAKE snapgear embedded linux 3.0.0

kamal kumar kamal at brothom.nl
Fri Oct 24 16:27:11 UTC 2003


I have the m68k-elf-tools.
I have the SnapGear Embedded Linux (3.0.0) distribution.
I have configured the distribution as following:

	make xconfig->
Then i got the configuring menu and chose:
	Vendor/product selection: 	motorola/m5272C3

	Kernel/libray/defaults selection->	kernel version:	linux-2.4.x
							libc version:	uClibc
							default all settings (lose changes):N
							costumize kernel setting: N
							costumize vendor/user settings: N
							update default vendor settings : N

Then i saved and exited.
After this i got some questions about options for uClibc but i forgot to write 
down what i filled in.

After this i ran MAKE DEP.
This proces went well.

After this i ran MAKE.
And then i got the following error:

m68k-elf-gcc  -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing  
-Os  -O2 -g -fomit-frame-pointer -m5307 -DCONFIG_COLDFIRE -fno-builtin 
-DEMBED -msep-data -I/root/snapgear/snapgear/lib/uClibc/include 
-I/root/snapgear/snapgear -Dlinux -D__linux__ -D__uClinux__ -Dunix 
-I/root/snapgear/snapgear/linux-2.4.x/include   -fno-builtin -nostdinc 
-D_LIBC -I../../include -I. -I/usr/local/lib/gcc-lib/m68k-elf/2.95.3/include 
-DNDEBUG -msoft-float -DL__fpmaxtostr printf.c -c -o _fpmaxtostr.o
printf.c: In function `_fpmaxtostr':
printf.c:2451: internal error--insn does not satisfy its constraints:
(insn 1899 672 673 (set (reg:QI 8 %a0)
        (mem:QI (plus:SI (reg:SI 15 %sp)
                (const_int 111 [0x6f])) 0)) 52 {movstrictqi-1} (nil)
make[4]: *** [_fpmaxtostr.o] Error 1
make[4]: Leaving directory `/root/snapgear/snapgear/uClibc/libc/stdio'
make[3]: *** [_dir_stdio] Error 2
make[3]: Leaving directory `/root/snapgear/snapgear/uClibc/libc'
make[2]: *** [_dir_libc] Error 2
make[2]: Leaving directory `/root/snapgear/snapgear/uClibc'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/root/snapgear/snapgear/lib'
make: *** [subdirs] Error 1

I suspect that this error has something to do with filling in the options i 
got for the uClibc.

Maybe someone can help me to give the right awnsers to the questions of 

I want to make a hello world program in C that runs in the MCF5272C3 board.

Thank you,

Kamal Kumar

More information about the uClibc mailing list