[uClibc] Uclibc 0.9.20 with sh3eb (sh-linux) g++v3

alain volmat avolmat at yahoo.fr
Tue Oct 14 14:52:19 UTC 2003

Hi all,

I'm trying to use uClibc 0.9.20 on a SH3 big endian
architecture running linux-sh kernel version 2.4.19.
I've got no problem (well .. almost big problems) when
compiling C program but it is slighly different with
C++ programs.
I've tried to compile flnx-0.17 for nano-X but I got
error during compilation since there is no file
iostream.h under the g++v3 directory in the include
subdirectory. Actually I noticed that when I do "make
CROSS=sh3eb-linux- install" to create the directory
/usr/sh-uclibc-linux with all compiler and all for the
uclibc I got no g++v3 directory created inside the
include directory (do you still follow ??)

Anyway, I searched on the mailing list archive and I
saw there is some question about g++-v3 issue but
actually nothing about SH.

I have some questions:
is it normal that I got no g++v3 directory created
when I do "make install" of uclibc ? (by the way, I
also tried without CROSS-compiling .. ie i386 but I
got exactly the same result .. no g++-v3 directory).

what should I do to compile C++ programs with uclibc.

does anybody use uclibc on a SH3 Big endian
architecture ?

I attach my .config file of uclibc here, just in case
it would help to understand.


Do you Yahoo!?
The New Yahoo! Shopping - with improved product search
-------------- next part --------------
A non-text attachment was scrubbed...
Name: .config
Type: application/octet-stream
Size: 1441 bytes
Desc: .config
Url : http://lists.busybox.net/pipermail/uclibc/attachments/20031014/2d689b68/attachment.obj 

More information about the uClibc mailing list