[uClibc] Buildroot: binutils problems

tom at ceisystems.com tom at ceisystems.com
Mon Oct 13 23:35:16 UTC 2003

Hello all,
	I've worked on my previous post, and decided to hang it all and
build a native toolchain. Now, I'm having other issues.  At the risk of
sounding like a complete fool, has anybody had any issues with the build
process of binutils for the target?  Here's my error:

creating lib/Makefile
make[2]: Entering directory
Making all in .
make[3]: Entering directory
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory
cd ../libiberty && make new_demangler
/bin/sh: line 1: cd: ../libiberty: No such file or directory
make[2]: *** [new_demangler] Error 1
make[2]: Leaving directory
make[1]: *** [all-build-demangler] Error 2
make[1]: Leaving directory
make: ***
ls/objdump] Error 2

	The configure process seems to complete correctly, and I believe
all the correct paths are being passed to `make`.  I put some echo's in
the .mk file, and tracked down the issue to the actually build process
(found in the objdump section).  So, I tried to step back two version
from CVS.  No difference.  So, does anybody have an idea as to why I am
getting this error?  I can confirm that, in fact, the libiberty
directory does not exist in the _current_ (build_i386/binutils-target)

Thanks for any help!
Thomas Cameron

More information about the uClibc mailing list