[uClibc] perl compilation

Michael Rowley os2doc at bellsouth.net
Fri Oct 3 02:42:59 UTC 2003

Hello all,

Having difficulty.  Perl won't compile on my box with buildroot.  Thats
OK, what I want is a perl package to install in a small box.  Here's
what I did:

Get latest root_fs_i386 29Sep03
cp to my local drive
chroot to path
download perl-5.8.0|tar -zxfv perl-5.8.0.tar.gz
patch -p0 <perl.patch(1.2 from uclibc.org)
./Configure for my target
First error is from deps.  For some reason it puts a '0' at the first
line of the depends.  I delete this and the compile continues.  But___
fails later on with a makefile in x2p "cant' find perlmain.c" ?!?

So, start again, this time extract perl_cross_0.1.tar, run patch as
above (it gave me an error that it couldn't find cross anyway) (still
gives me an error and creates a new directory
"perl-5.8.0.uclibc/cross/config.sh.uclibc"  This doesn't seem right.
cp config.sh.uclibc to ../perl-5.8.0/cross/
hunky dory! :)
death, famine, pestilence, failure!

Hmm, never being one to give up easily, search the uclibc.org site,
couple of references, lots of people saying "worked for me".  Hmm

Try new extraction for perl-5.8.0.tar.gz (rm -rf perl-5.8.0) compile. 
Can't get the compiler to work... grr.

Tried this with my own root_fs from buildroot, and the newest downloaded
on as mentioned above.  


Althalon 800 256meg
redhat 9.1 with latest updates.
latest root_fs from uclibc, chroot


More information about the uClibc mailing list