[uClibc]e2fsck problem: (Bad address) while doing inode scan

Giulio Orsero giulioo at pobox.com
Mon Mar 31 19:19:16 UTC 2003

On Mon, 31 Mar 2003 11:37:51 -0700, Erik Andersen <andersen at codepoet.org>

>> I might have messed up with uclibc. Maybe e2fsprogs misdetects uclibc
>> headers and self-configure with wrong assumptions at compile time?
>This sounds fairly likely...  Tried doing an strace and comparing
>calls to lseek?  When you _compile_ e2fsck are you also compiling 
>it using 2.0 or 2.2 kernel header files?  Perhaps e2fsprogs is
I compiled e2fsprogs with and without any headers installed, because I
thinks it should always use automatically the headers inside uclibc dirs,
I compiled it on a 2.2 system too (which has never seen 2.4.x), just to be

So far, I always tried wih uclibc compiled on a 2.4 system (Red Hat 7.3)
with kernel source pointing to a 2.2.19 tree; I verified version.h inside
uclibc installed/runtime/devel tree is 2.2.x.

I tried compiling uclibc too on a 2.2 system (Red Hat 6.x) but it fails due
to ld not supporting -init.

giulioo at pobox.com

More information about the uClibc mailing list