[uClibc]unresolved symbols

Allan Clark allanc at sco.com
Thu Mar 20 16:09:35 UTC 2003


Since these are in libgcc.a, they should be linked static into your
module, making use/non-use of uClibc a moot point, since the object code
is in your compiled target.

what does the output of "nm igateway.o | grep udivdi3" look like?

You *should* see something like "00000000 T __udivdi3" of course; if you
have "U __udivdi3", then I think you need to recompile with the
following option:


.. I think...  not an expert, just thinking aloud.

This might not affect the biuld process under uClibc, might not make it
through a wrapper, I dunno.


Yugandhar wrote:
> Hi,
>    I have an BRECIS MSP 4000 board. I have built the uClinux2.0 Beta Two
> kernel and booted the board. After that when i tried to insmod my
> driver(with uClibc3.2) which contains proprietary firewall and vpn) i got
> the following errors.
> igateway.o: unresolved symbol __udivdi3
> igateway.o: unresolved symbol __umoddi3
> These symbols are defined in libgcc.a
> Whereas while i worked with uCLinux1.1.4(with uClibc 3.1) i had no problem
> insmod-ing the same driver.
> Openssl is used.What could be the problem.Any help is greatly appreciated.
> Thank you.
> Yugandhar
> _______________________________________________
> uClibc mailing list
> uClibc at uclibc.org
> http://uclibc.org/mailman/listinfo/uclibc

More information about the uClibc mailing list