[uClibc]mmap bug in uClibc 0.9.19 on mips

Sirotkin, Alexander demiurg at ti.com
Thu Mar 6 16:50:40 UTC 2003

Yep, it fixes the problem. 
Can you please add this to the 0.9.20 release ?

Erik Andersen wrote:

On Thu Mar 06, 2003 at 05:16:44PM +0200, Sirotkin, Alexander wrote:


Just tried uClibc on our mips platform and discovered

the mmap bug.

I'm still not sure what exactly happens, mmap() returns

a valid address but it does not point to a correct physical

memory address.

The same code works on 0.9.16 and with glibc.


Could you check if applying this to uClibc make mmap 

work as expected on mips?  It may be that the mmap2

syscall is totally broken on mips,

--- libc/sysdeps/linux/mips/_mmap.c	26 Feb 2003 02:13:55 -0000

+++ libc/sysdeps/linux/mips/_mmap.c	6 Mar 2003 15:45:50 -0000

@@ -5,7 +5,9 @@

 #include <sys/syscall.h>


+#if 0

 #ifdef __NR_mmap2

 # undef __NR_mmap

 # define __NR_mmap __NR_mmap2






Erik B. Andersen              http://codepoet-consulting.com/

--This message was written using 73% post-consumer electrons--



Alexander Sirotkin

SW Engineer

Texas Instruments

Broadband Communications Israel (BCIL)

Tel:  +972-9-9706587


"Those who do not understand Unix are condemned to reinvent it, poorly."

      -- Henry Spencer 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.busybox.net/pipermail/uclibc/attachments/20030306/0c4eacd3/attachment-0001.htm 

More information about the uClibc mailing list