[uClibc]Error with arm, buildroot, and root_fs - unresolved symbol __umodsi3

Christopher Hoover ch at murgatroid.com
Thu Mar 6 16:59:58 UTC 2003


I just tried 2.95.4/0.9.19.  It works fine (== init starts, I can log
in, etc.) *without* ADD_LIBGCC_FUNCTIONS.

I'll give 3.2.2 another shot with ADD_LIBGCC_FUNCTIONS enabled.

-ch


-----Original Message-----
From: Erik Andersen [mailto:andersen at codepoet.org] 
Sent: Thursday, March 06, 2003 6:08 AM
To: Christopher Hoover
Cc: uclibc at uclibc.org
Subject: Re: [uClibc]Error with arm, buildroot, and root_fs - unresolved
symbol __umodsi3


On Wed Mar 05, 2003 at 07:03:32PM -0800, Christopher Hoover wrote:
> 
> I'm running into this, too, on ARM:
> 
> init: can't resolve symbol '__umodsi3'
> Kernel panic: Attempted to kill init!
> 
> 
> I am using a 3.2.2/0.9.19 cross (from x86) toolchain.  Previously I
was
> using 2.95.4/0.9.12, which worked fine.  The scripts to build the root
> image haven't changed.

Enable ADD_LIBGCC_FUNCTIONS in your uClibc .config file.
I think I may just force that option enabled for ARM targets
since it seems to be an essential ingredient for arm to work,

 -Erik

--
Erik B. Andersen             http://codepoet-consulting.com/
--This message was written using 73% post-consumer electrons--




More information about the uClibc mailing list