[uClibc]buildroot not building correctly

Stacy D. Coil coil.1 at osu.edu
Thu Oct 31 20:06:16 UTC 2002


I guess I should have said that I am building this for the i386 
architecture with mmu.

--Stacy


At 02:44 PM 10/31/2002 -0500, Stacy D. Coil wrote:
>Hello,
>
>I am trying to build the buildroot source and keep getting errors.  I've 
>tried using the latest releases for busybox and uclibc and the snapshots 
>to now avail.  Are the any distructions as the README is a little sparse.
>
>Will the make file create a statically linked source?  If it does, how 
>does one created a build using shared libraries?
>
>Here is the output that I am getting:
>
>perl -i -p -e 's,^HAS_WCHAR.*,HAS_WCHAR=false,g' 
>/home/coil/buildroot/build/uClibc/Config
># Note that since the target compiler does not yet exist, we will not
># be able to properly generate include/bits/syscall.h so we will need
># to run part again later...
>make -C /home/coil/buildroot/build/uClibc headers uClibc_config install_dev;
>make[1]: /home/coil/buildroot/build/staging_dir/bin/i386-uclibc-gcc: 
>Command not found
>make[1]: Entering directory `/home/coil/buildroot/build/uClibc'
>¨ßB¨ßBrm -f include/asm;
>
>The path '/usr/src/linux/include/asm' doesn't exist.
>I bet you didn't set KERNEL_SOURCE, TARGET_ARCH or HAS_MMU in `Config'
>correctly.  Please edit `Config' and fix these settings.
>
>make[1]: *** [headers] Error 1
>make[1]: Leaving directory `/home/coil/buildroot/build/uClibc'
>make: *** [/home/coil/buildroot/build/uClibc/.configured] Error 2
>
>Thanks for your help,
>
>--Stacy
>
>
>_______________________________________________
>uClibc mailing list
>uClibc at uclibc.org
>http://uclibc.org/mailman/listinfo/uclibc




More information about the uClibc mailing list