[uClibc]Using uclibc in MIPS architecture

Rajesh Katragadda rajesh.katragadda at wipro.com
Fri Oct 4 05:01:39 UTC 2002

    thanks for ur reply. Yah while running the application, I checked the following commands:
    $ mipsel-uclibc-ldd myprogram
        libc.so.0 => /home/rajesh/usr/mipsel-linux-uclibc/lib/libc.so.0
        /home/rajesh/lib/ld-uClibc.so.0 => /home/rajesh/lib/ld-uClibc.so.0
    $ file myprogram  
    myprogram: ELF 32-bit LSB executable, MIPS R3000_BE - invalid byte order, version 1, dyn
    amically linked (uses shared libs), not stripped 
 Rajesh K  

-----Original Message-----
From: Joseph Chiu [mailto:josephc at idealab.com] 
Sent: Friday, October 04, 2002 1:25 AM
To: Rajesh Katragadda
Subject: RE: [uClibc]Using uclibc in MIPS architecture

Hmm, I suggest first making sure that your shared-library program compiled correctly and are linked to the uclibc libraries...
try "mipsel-uclibc-ldd myprogram" and make sure you're pointing only to the uclibc shared library.
And, as a complete sanity check, try "file myprogram" and make sure it reports as a MIPS ELF dynamic program.
-----Original Message-----
From: uclibc-admin at uclibc.org [mailto:uclibc-admin at uclibc.org]On Behalf Of Rajesh Katragadda
Sent: Sunday, September 29, 2002 10:33 PM
To: uclibc at uclibc.org
Subject: [uClibc]Using uclibc in MIPS architecture

      I am trying to use busybox(version-0.51) and user applications 
compiled against uclibc(0.9.15) on IDTRP355 board(MIPS arch, LE).
Busybox is compiled with --static option and is working fine 
on board as it is not using shared libraries. I wrote a small 
application as follows:
#include <stdio.h>
int main()
    return 0;
I compiled above application against uclibc with shared libraries support
 and tried to run on IDTRP355 board. It is giving "Invalid ELF header" message.
I tried to debug this error message and found out that the  load address of ELF 
interpreter is getting NULL.
Please help me to sort out this problem.
Rajesh K

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.busybox.net/pipermail/uclibc/attachments/20021004/abdbe310/attachment-0001.htm 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Wipro_Disclaimer.txt
Url: http://lists.busybox.net/pipermail/uclibc/attachments/20021004/abdbe310/attachment.txt 

More information about the uClibc mailing list